[Architecture] couchdb upgrade

Tyler Roscoe tyler at raisingthefloor.org
Tue Apr 23 03:28:07 UTC 2019


As mentioned in the last Architecture Weekly, we need to upgrade couchdb to
2.3 for security patches: https://issues.gpii.net/browse/GPII-3846

The only place I could find (outside of gpii-infra) that references a
couchdb version is in universal, where it uses latest (which means that
universal CI has been using the new couchdb since it was released):
https://github.com/GPII/universal/blob/master/scripts/vagrantCloudBasedContainers.sh#L31

Does anyone know of other areas that need to be updated?

Ops will perform the couchdb upgrade in production at our convenience. We
believe the upgrade is low risk and will cause minimal downtime (on the
order of seconds). However, let us know if you have any concerns.

Thanks,
t
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.gpii.net/pipermail/architecture/attachments/20190422/4dc65714/attachment.html>


More information about the Architecture mailing list